Slowness when navigating website after Login

Incident Report for Constant Contact

Resolved

Stability has been restored for users experiencing slowness after logging into accounts and for users navigating within the site.
Posted Apr 01, 2025 - 22:16 EDT

Investigating

Currently, some customers are experiencing slow and intermittent page loads upon logging into their accounts. Teams are actively working to resolve this issue.
Posted Apr 01, 2025 - 18:26 EDT
This incident affected: Login.