Email Sending Delay
Incident Report for Constant Contact
Resolved
This incident has been resolved.
Posted Sep 07, 2023 - 14:40 EDT
Update
A fix has been implemented and scheduled emails are sending. There may still be a slight delay for some emails as we process the backlog of emails.
Posted Sep 07, 2023 - 12:20 EDT
Monitoring
A fix has been implemented and scheduled emails are sending. There may still be a slight delay for some emails as we process the backlog of emails.
Posted Sep 07, 2023 - 10:49 EDT
Identified
The issue has been identified and teams are working on implementing a fix as soon as possible.
Posted Sep 07, 2023 - 09:15 EDT
Investigating
Some customer emails may be delayed as we are experiencing an issue with the sending emails. We are working on resolving this as quickly as possible.
Posted Sep 07, 2023 - 07:28 EDT
This incident affected: Email Delivery (Email Campaigns, Email Automation).