Difficulty Logging In
Incident Report for Constant Contact
Resolved
The incident has been resolved
Posted Jun 12, 2023 - 12:56 EDT
Identified
The root cause has been identified and we are implementing a fix.
Posted Jun 12, 2023 - 12:35 EDT
Investigating
Some customers are experiencing difficultly logging into our website. We are working hard to resolve it as quickly as possible.
Posted Jun 12, 2023 - 12:15 EDT
This incident affected: Login.