Emails not being received to domains hosted on Microsoft Office 365
Incident Report for Constant Contact
Resolved
After working with Microsoft the issue has been resolved and delivery of email to Microsoft Office 365 is working as expected.
Posted Nov 08, 2023 - 20:00 EST
Update
We continue to work with Microsoft to resolve the issue.
Posted Nov 08, 2023 - 08:15 EST
Investigating
Our Deliverability Team is currently investigating reports of emails not being received to domains hosted on Microsoft Office 365.

These messages are not bouncing but are not arriving at the destination Inbox or Junk Folders.
Posted Nov 07, 2023 - 15:58 EST
This incident affected: Email Delivery (Email Campaigns).