Issues Connecting to Constant Contact Support
Incident Report for Constant Contact
Resolved
A fix has been implemented and the issue has been resolved
Posted Apr 13, 2023 - 09:16 EDT
Investigating
Customers are experiencing difficulties calling into support. We are working to fix this issue as quickly as possible Please visit our Help Center for other support resources during this time.
Posted Apr 13, 2023 - 08:25 EDT
This incident affected: Contact Center.