Issues with billing and making payments

Incident Report for Constant Contact

Resolved

We have resolved the issue with billing, and payments are processing normally.
Posted Aug 04, 2025 - 21:13 EDT

Investigating

We are currently experiencing issues affecting customers ability to change payment methods or make payments. Customers may encounter an error when attempting to process payments. We appreciate your patience as we work to resolve this issue.
Posted Aug 04, 2025 - 18:06 EDT
This incident affected: My Account & Billing.