Issues with Constant Contact's main site and login page
Incident Report for Constant Contact
Resolved
The website is back to normal operation and the underlying issue has been resolved.
Posted Oct 30, 2023 - 16:19 EDT
Update
We are continuing to investigate this issue.
Posted Oct 30, 2023 - 16:15 EDT
Update
When attempting to navigate to Constant Contact's website, customers may encounter an error. We are aware of this issue, and are investigating the root cause. Customers may attempt to login by navigating directly to the login page: https://login.constantcontact.com/login/ We apologize for any inconvenience this has caused.
Posted Oct 30, 2023 - 16:00 EDT
Investigating
When attempting to navigate to Constant Contact's website or login page, customers may encounter an error. We are aware of this issue, and are investigating the root cause. We apologize for any inconvenience this has caused.
Posted Oct 30, 2023 - 15:59 EDT
This incident affected: Login and ConstantContact.com.