Email bounces to ProofPoint Email Protection
Incident Report for Constant Contact
Resolved
The ProofPoint delivery issue has been resolved and email delivery is successful going forward.
Posted May 12, 2023 - 13:53 EDT
Investigating
We are currently experiencing some issues delivering mail through the ProofPoint Email Protection service (a third-party security program). This is causing some emails to bounce and will likely show an increase in "undeliverable" bounces within your reporting. We are working with ProofPoint to resolve the issue as quickly as possible.
Posted May 11, 2023 - 16:44 EDT
This incident affected: Email Delivery (Email Campaigns).