AWS Outage Affecting Constant Contact
Incident Report for Constant Contact
Resolved
This incident has been resolved.
Posted Jun 13, 2023 - 16:50 EDT
Monitoring
AWS has implemented a fix. Emails are sending and other parts of the system that were affected have recovered. We will continue to monitor for any issues.
Posted Jun 13, 2023 - 16:38 EDT
Identified
The issue has been identified and we are monitoring the AWS outage.
Posted Jun 13, 2023 - 15:54 EDT
Update
We are continuing to investigate this issue.
Posted Jun 13, 2023 - 15:33 EDT
Investigating
There is currently a widespread AWS outage affecting several components of the Constant Contact suite. There may be issues accessing and managing various features in your accounts and sending emails to segments. At this time, we recommend that you do not schedule any campaigns to segments until the AWS issue is resolved. This issue is not specific to Constant Contact, but we are monitoring the situation and will provide updates as we know more.
Posted Jun 13, 2023 - 14:49 EDT
This incident affected: Email Delivery (Email Campaigns), Contacts (Segments), Campaign Creation (Survey Creation), and Landing Pages, API's and Integrations, My Account & Billing.