Issues Creating Sign-up Forms

Incident Report for Constant Contact

Resolved

This incident has been resolved.
Posted 1 year ago. Apr 04, 2024 - 21:15 EDT

Investigating

Some customers are experiencing issues creating Sign-up Forms. We are working to resolve the issue as quickly as possible.
Posted 1 year ago. Apr 03, 2024 - 22:28 EDT
This incident affected: Contacts (Contact Management).