Issues posting to Facebook and Instagram 12/11/24
Incident Report for Constant Contact
Resolved
This incident has been resolved.
Posted Dec 11, 2024 - 19:03 EST
Investigating
We are currently experiencing issues posting to Facebook and Instagram. This is due to a Meta outage and we are actively monitoring the situation.
Posted Dec 11, 2024 - 14:29 EST
This incident affected: Social Media.