Login with Facebook is temporarily unavailable
Incident Report for Constant Contact
Resolved
The issues has been resolved. Customers are able to use the login with Facebook option to access their account.
Posted Jul 19, 2023 - 03:00 EDT
Identified
Currently, customers who use the login with Facebook option to access their account are unable to log in. We are working with Facebook to resolve this issue. If affected customers have Constant Constant login credentials, they can use those to access their account.
Posted Jul 18, 2023 - 12:11 EDT
This incident affected: Login.