Email Campaigns: A Service Disruption is In Effect
Incident Report for Constant Contact
Resolved
The underlying issue has been identified and addressed, campaigns that were affected have been sent.
Posted Apr 15, 2023 - 12:01 EDT
Investigating
We are experiencing issues with loading and editing campaigns. We also are experiencing difficulty in sending email campaigns. Some campaigns may fail to send due to this issue. We are working on resolving this as quickly as possible.
Posted Apr 15, 2023 - 07:14 EDT
This incident affected: Campaign Creation (Email Campaigns) and Email Delivery (Email Campaigns).