Constant Contact Phone System is Unavailable
Incident Report for Constant Contact
Resolved
The phone issue has been resolved. Customers can successfully call in during business hours.
Posted Jun 15, 2023 - 21:40 EDT
Identified
Customers are experiencing difficulties calling into support and sales agents. We are working with our phone system provider to fix this issue as quickly as possible Please visit our Help Center for other support resources during this time.
Posted Jun 15, 2023 - 18:06 EDT
This incident affected: Contact Center.