Issues logging into accounts
Incident Report for Constant Contact
Resolved
This incident has been resolved.
Posted Feb 10, 2023 - 14:26 EST
Update
We are continuing to monitor for any further issues.
Posted Feb 10, 2023 - 14:13 EST
Monitoring
A fix has been implemented and customers are able to log in to account. We will continue to monitor the situation.
Posted Feb 10, 2023 - 14:06 EST
Investigating
Currently, some customers are experiencing difficultly logging into accounts. We are currently working to resolve this issue.
Posted Feb 10, 2023 - 13:49 EST
This incident affected: Login.