Difficulty Calling Into Support
Incident Report for Constant Contact
Resolved
Our phone system provider has implemented a fix, and systems are fully operational.
Posted Jan 04, 2023 - 15:10 EST
Monitoring
Our phone system provider has implemented a fix. Our support agents are able to take support calls and we are currently monitoring the situation for any additional issues.
Posted Jan 04, 2023 - 14:28 EST
Identified
The issue has been identified and our phone system provider is working to implement a fix.
Posted Jan 04, 2023 - 13:31 EST
Investigating
Customers are experiencing difficulties calling into support. We are working with our phone system provider to fix this issue as quickly as possible. Please use our chat support or visit our Help Center for other support resources during this time.
Posted Jan 04, 2023 - 13:05 EST
This incident affected: Contact Center.