Product Navigation Issues

Incident Report for Constant Contact

Resolved

This incident has been resolved and we will continue to monitor the issue.
Posted Oct 20, 2025 - 12:48 EDT

Investigating

We are currently investigating reports of intermittent navigation issues affecting some customers. Our team is actively working to identify and resolve the root cause. We apologize for the disruption as we work to resolve this issue.
Posted Oct 20, 2025 - 11:43 EDT
This incident affected: My Account & Billing.