Email Sending Delays

Incident Report for Constant Contact

Resolved

We have implemented a fix and all systems are are operational.
Posted Feb 15, 2023 - 12:29 EST

Investigating

We are currently experiencing an issue that is causing a sending delay for a small number of campaigns. We are working to resolve this as quickly as possible.
Posted Feb 15, 2023 - 11:54 EST
This incident affected: Email Delivery (Email Campaigns).