Issues Accessing Landing Pages and Survey Pages

Incident Report for Constant Contact

Resolved

This incident has been resolved
Posted Feb 21, 2023 - 11:45 EST

Investigating

Some customers have reported issues accessing their Landing pages and Survey pages. We are aware of the issue and are working to resolve it quickly.
Posted Feb 21, 2023 - 10:47 EST
This incident affected: Campaign Creation (Survey Creation) and Landing Pages, Reporting.