Outlook 365 email deliverability issues
Incident Report for Constant Contact
Resolved
This incident has been resolved.
Posted Jan 24, 2024 - 12:00 EST
Investigating
Our Deliverability and ISP Relations Team is currently investigating reports of emails not being received to domains hosted on Microsoft Office 365.

These messages are not bouncing but instead are landing in the junk folder or hidden in admin quarantine.
Posted Jan 23, 2024 - 12:16 EST
This incident affected: Email Delivery (Email Campaigns).