Email Delivery Delays

Incident Report for Constant Contact

Resolved

This incident has been resolved and all delayed mail has been sent.
Posted Feb 25, 2026 - 15:22 EST

Investigating

We are currently experiencing delays when attempting to deliver emails. Our engineers are aware of the inconvenience and are working towards a resolution.
Posted Feb 25, 2026 - 14:51 EST
This incident affected: Email Delivery (Email Campaigns, Email Automation).