Delays in test email delivery

Incident Report for Constant Contact

Resolved

Test mail delivery has resumed and there should be no further delays.
Posted Nov 19, 2025 - 17:05 EST

Investigating

We are currently experiencing delays when attempting to deliver test emails. Our engineers are aware of the inconvenience and are working towards a resolution.
Posted Nov 19, 2025 - 13:49 EST
This incident affected: Email Delivery (Email Campaigns).