Delays with Segments and Automation Path Starts

Incident Report for Constant Contact

Resolved

These delays have been resolved and both Segments and APB paths are working as expected.
Posted Jul 25, 2026 - 16:30 EDT

Investigating

Customers may experience delays with updates contacts a part of new and existing Segments. Customers may also experience delays with contacts starting an Automation path campaign. We are actively investigating this issue. We apologize for any inconveniences and appreciate your patience.
Posted Jul 23, 2026 - 19:50 EDT
This incident affected: Email Delivery (Email Automation) and Contacts (Segments).