Payment collection issue
Incident Report for Constant Contact
Resolved
This incident has been resolved.
Posted May 12, 2023 - 12:30 EDT
Update
We are continuing to investigate this issue.
Posted May 12, 2023 - 12:00 EDT
Investigating
The third party service we use to collect payments is experiencing issues. As a result some customers are having trouble completing payment and updating credit card information in their account. We are working with our service provider to fix this as soon as possible.
Posted May 12, 2023 - 11:30 EDT
This incident affected: My Account & Billing.