Unable to view partner organization reporting

Incident Report for Constant Contact

Resolved

This issue has been resolved
Posted Sep 14, 2026 - 18:42 EDT

Investigating

Partner customers may experience an error when attempting to use the organization reporting beta feature. Our engineers are aware of this error, and it's being actively researched.
Posted Sep 14, 2026 - 15:09 EDT
This incident affected: Reporting.