Campaigns Page Not Loading
Incident Report for Constant Contact
Resolved
The campaigns page is now loading as expected and the issue is now resolved.
Posted Dec 19, 2022 - 12:12 EST
Investigating
Teams have been notified of this issue and are currently working to identify the root cause of the issue.
Posted Dec 19, 2022 - 11:59 EST
This incident affected: Campaign Creation (Email Campaigns).