Slowness when logging in and navigating within the account (6/23/2026)

Incident Report for Constant Contact

Resolved

This incident has been resolved.
Posted Jun 23, 2026 - 15:25 EDT

Identified

Customers may experience slowness when attempting to log into or navigate within their account. Our engineers are aware of this, and are researching the issue now. We apologize for any delays this may cause.
Posted Jun 23, 2026 - 14:37 EDT
This incident affected: Login.