Issues Creating, Editing and Sending Campaigns

Incident Report for Constant Contact

Resolved

The incident has been resolved.
Posted Mar 08, 2024 - 12:51 EST

Update

Customers may experience an error when attempting to schedule email campaigns, or when working on landing pages. We are actively researching these issues and apologize for the inconvenience.
Posted Mar 08, 2024 - 12:12 EST

Identified

A fix has been implemented and scheduled emails are sending. There may still be a slight delay for some emails as we process the backlog of emails. We're still working on an issue with Landing Pages at this time.
Posted Mar 08, 2024 - 11:00 EST

Investigating

We are currently experiencing a system issue resulting in users being unable to edit, create, and send campaigns. We are working to resolve the issue as quickly as possible.
Posted Mar 08, 2024 - 08:25 EST
This incident affected: Campaign Creation (Email Campaigns, Event Campaigns, Survey Creation, Email Automation), Email Delivery (Email Campaigns, Email Automation), and Landing Pages.