Experiencing issues with loading and editing campaigns
Incident Report for Constant Contact
Resolved
The Issue has been identified and has been resolved.
Posted Nov 14, 2022 - 15:54 EST
Update
We are continuing to investigate this issue.
Posted Nov 14, 2022 - 15:17 EST
Investigating
We are experiencing issues with loading and editing campaigns, your emails may be slightly delayed while we investigate the issue. We are working on resolving this as quickly as possible.
Posted Nov 14, 2022 - 15:17 EST
This incident affected: Campaign Creation (Email Campaigns, Event Campaigns, Survey Creation, Email Automation) and Email Delivery (Email Campaigns, Email Automation).