Error loading Campaign and Social pages
Incident Report for Constant Contact
Resolved
The incident has been resolved.
Posted Feb 08, 2023 - 15:03 EST
Investigating
Currently, some of our customers are experiencing an error when trying to load the campaign and social pages. We are aware of this issue and are working to resolve it.
Posted Feb 08, 2023 - 14:27 EST
This incident affected: Campaign Creation (Email Campaigns) and Social Media.