Error When Scheduling Campaign
Incident Report for Constant Contact
Resolved
This incident has been resolved.
Posted Feb 13, 2024 - 08:18 EST
Investigating
Some of our customers are experiencing an error while attempting to schedule a campaign. We are working to resolve this as quickly as possible.
Posted Feb 13, 2024 - 06:51 EST
This incident affected: Email Delivery (Email Campaigns).