Partner SSO Login
Incident Report for Constant Contact
Resolved
The Single Sign-On issue has been resolved and customers can successfully log in.
Posted Jun 15, 2023 - 21:39 EDT
Identified
The issue has been identified and a fix is being implemented
Posted Jun 15, 2023 - 15:43 EDT
Investigating
Some Partners are experiencing issues when attempting to login to their accounts via SSO (Single-Sign-On). We are working hard to resolve it as quickly as possible.
Posted Jun 15, 2023 - 14:44 EDT
This incident affected: Login.