Issues Managing Contacts and Scheduling Emails
Incident Report for Constant Contact
Resolved
This incident has been resolved
Posted Jun 30, 2023 - 18:00 EDT
Investigating
We are experiencing an issue with our contact management system that will result in errors trying to manage your contacts and schedule emails. We are working on resolving this as quickly as possible.
Posted Jun 30, 2023 - 16:34 EDT
This incident affected: Campaign Creation (Email Campaigns) and Contacts (Contact Management).