Issues Accessing Campaigns and Reporting Data

Incident Report for Constant Contact

Resolved

This incident has been resolved.
Posted 11 months ago. May 03, 2024 - 17:10 EDT

Investigating

Some of our customers are experiencing issues accessing campaigns and reporting data. We are working to resolve this as quickly as possible.
Posted 11 months ago. May 03, 2024 - 11:48 EDT
This incident affected: Campaign Creation (Email Campaigns, Event Campaigns, Survey Creation, Email Automation) and Reporting.