Email Delivery Delays due to Microsoft Outage

Incident Report for Constant Contact

Resolved

This incident has been resolved.
Posted Jan 23, 2026 - 03:30 EST

Update

We are continuing to monitor for any further issues.
Posted Jan 22, 2026 - 16:16 EST

Monitoring

Some users may experience delays when sending emails to Microsoft hosted email addresses. Currently, there is a Microsoft outage that may impact when email is received. We are monitoring the situation. https://status.cloud.microsoft/
Posted Jan 22, 2026 - 14:30 EST
This incident affected: Email Delivery (Email Campaigns, Email Automation).