Delay in sending emails
Incident Report for Constant Contact
Resolved
This incident has been resolved.
Posted May 03, 2024 - 11:46 EDT
Monitoring
A fix has been implemented and mail is sending as expected. We are continuing to monitor the situation.
Posted May 03, 2024 - 11:21 EDT
Investigating
Some of our customers are experiencing a delay in sending email campaigns. We are working to resolve this as quickly as possible.
Posted May 03, 2024 - 10:03 EDT
This incident affected: Email Delivery (Email Campaigns).