Website Down

Incident Report for Constant Contact

Resolved

This incident has been resolved.
Posted Nov 16, 2022 - 19:49 EST

Monitoring

A fix has been implemented and we are monitoring the issue.
Posted Nov 16, 2022 - 19:36 EST

Identified

We have Identified the issue and are implementing a fix.
Posted Nov 16, 2022 - 19:35 EST

Update

We are continuing to investigate this issue.
Posted Nov 16, 2022 - 18:30 EST

Investigating

We are currently experiencing an issue with our website. To log in to your account please go directly to login.constantcontact.com. We are working on resolving this as quickly as possible.
Posted Nov 16, 2022 - 18:16 EST
This incident affected: ConstantContact.com.