Landing Page Editing Issue

Incident Report for Constant Contact

Resolved

This incident has been resolved.
Posted May 30, 2024 - 17:18 EDT

Investigating

We are experiencing an issue with editing the contact fields in landing pages. Our engineers are aware of this issue, and are working to resolve it.
Posted May 30, 2024 - 11:19 EDT
This incident affected: Landing Pages.