Login with Facebook is temporarily unavailable
Incident Report for Constant Contact
Resolved
This incident has been resolved.
Posted Aug 05, 2023 - 09:52 EDT
Investigating
Currently, customers who use the login with Facebook option to access their account are unable to log in. We are working with Facebook to resolve this issue. If affected customers have Constant Constant login credentials, they can use those to access their account.
Posted Aug 02, 2023 - 10:50 EDT
This incident affected: Login.