Issues Loading Contact Lists and Scheduling SMS Campaigns
Incident Report for Constant Contact
Resolved
This incident has been resolved.
Posted Nov 15, 2024 - 10:36 EST
Investigating
We are currently investigating this issue.
Posted Nov 15, 2024 - 07:58 EST
This incident affected: Contacts (Contact Management) and SMS (SMS Sending).