Slow website navigation and email delivery

Incident Report for Constant Contact

Resolved

This incident has been resolved.
Posted Sep 16, 2026 - 15:22 EDT

Investigating

Customers may experience slowness when navigating within their Constant Contact accounts, as well as blank or empty pages. Additionally, we are experiencing delays in email campaign sending. We recommend leaving your campaign scheduled, as unscheduling and rescheduling may result in further delays.
Posted Sep 16, 2026 - 14:52 EDT
This incident affected: Email Delivery (Email Campaigns).