Error when creating new campaigns

Incident Report for Constant Contact

Resolved

This issue has been resolved and editor functionality has been restored to campaigns
Posted Jul 01, 2026 - 17:14 EDT

Investigating

Customers may encounter an error when attempting to create new campaigns, or when attempting to access or edit draft campaigns. We are aware of this issue and are working to resolve it as quickly as possible.
Posted Jul 01, 2026 - 16:30 EDT
This incident affected: Campaign Creation (Email Campaigns).