Issues with Events, Automations and Account Setting page

Incident Report for Constant Contact

Resolved

This incident has been resolved.
Posted 7 months ago. Aug 28, 2024 - 23:23 EDT

Update

We are continuing to investigate this issue.
Posted 7 months ago. Aug 28, 2024 - 23:23 EDT

Update

We are continuing to investigate this issue.
Posted 7 months ago. Aug 28, 2024 - 20:00 EDT

Investigating

Some customers are experiencing issues varying from Event creation and copying, Campaign scheduling, and other pages not successfully loading. Our teams are working hard to address these issues as quickly as possible.
Posted 7 months ago. Aug 28, 2024 - 19:56 EDT
This incident affected: Email Delivery (Email Campaigns), Campaign Creation (Event Campaigns, Email Automation), and Landing Pages, My Account & Billing.