Issues with loading and editing emails, delayed scheduled emails
Incident Report for Constant Contact
Resolved
Campaigns are successfully loading and scheduled campaigns are successfully sending.
Posted Feb 27, 2023 - 15:36 EST
Update
We are continuing to investigate this issue.
Posted Feb 27, 2023 - 15:33 EST
Update
We are continuing to investigate this issue.
Posted Feb 27, 2023 - 15:19 EST
Investigating
We are experiencing issues with loading and editing campaigns. Your scheduled emails may be slightly delayed while we investigate the issue. We are working on resolving this as quickly as possible.
Posted Feb 27, 2023 - 15:14 EST
This incident affected: Campaign Creation (Email Campaigns, Survey Creation, Email Automation), Email Delivery (Email Campaigns, Email Automation), and Social Media.