Delays in sending email

Incident Report for Constant Contact

Resolved

This issue has been resolved, and all scheduled email has been sent.
Posted Jul 07, 2026 - 16:32 EDT

Investigating

We are currently experiencing delays in sending test emails, as well as scheduled emails. Our engineers are aware of these delays and are working to resolve them as quickly as possible.
Posted Jul 07, 2026 - 11:23 EDT
This incident affected: Email Delivery (Email Campaigns).