Issues with resetting account passwords and adding new users
Incident Report for Constant Contact
Resolved
The incident has been resolved.
Posted Feb 14, 2024 - 13:01 EST
Update
We are continuing to investigate this issue.
Posted Feb 14, 2024 - 12:24 EST
Investigating
Some customers are experiencing issues with the reset password flow and adding new users. Our teams are working to resolve this issue as quickly as possible.
Posted Feb 14, 2024 - 10:30 EST
This incident affected: Login and My Account & Billing.