Issues saving campaigns
Incident Report for Constant Contact
Resolved
This incident has been resolved.
Posted Feb 14, 2023 - 13:51 EST
Update
Some customers are experiencing issues with saving and editing campaigns. Your emails may be slightly delayed while we investigate the issue. We are working on resolving this as quickly as possible.
Posted Feb 14, 2023 - 11:49 EST
Update
We are continuing to investigate this issue.
Posted Feb 14, 2023 - 11:14 EST
Investigating
Some customers are experiencing issues with saving and editing campaigns. We are working on resolving this as quickly as possible.
Posted Feb 14, 2023 - 10:30 EST
This incident affected: Campaign Creation (Email Campaigns) and Email Delivery (Email Campaigns).