Issues with Reporting Data and Loading Some Pages

Incident Report for Constant Contact

Resolved

This incident has been resolved.
Posted 10 months ago. Jun 13, 2024 - 17:01 EDT

Investigating

Some of our customers are experiencing issues loading campaigns pages and viewing reporting data. We are working to resolve this as quickly as possible.
Posted 10 months ago. Jun 13, 2024 - 16:40 EDT
This incident affected: Campaign Creation (Email Campaigns, Event Campaigns, Survey Creation, Email Automation) and Reporting.