Issues Logging In

Incident Report for Constant Contact

Resolved

Login functionality has been restored
Posted Dec 14, 2024 - 18:48 EST

Investigating

We are currently experiencing an issue causing customers to not be able to log in to their accounts. We are working to resolve the issue as soon as possible.
Posted Dec 14, 2024 - 18:19 EST
This incident affected: Login.