Delays Scheduling and Sending Emails

Incident Report for Constant Contact

Resolved

All delayed emails have been processed and sending functionality has been restored.
Posted 6 months ago. Oct 18, 2024 - 23:39 EDT

Update

All delayed emails have been processed and sending functionality has been restored.
Posted 6 months ago. Oct 18, 2024 - 23:38 EDT

Investigating

Some customers are currently unable to schedule emails and some emails are currently delayed. We are working to resolve the issue as quickly as possible.
Posted 6 months ago. Oct 18, 2024 - 21:11 EDT
This incident affected: Email Delivery (Email Campaigns, Email Automation).